CentOS6下RPM安装gcc和glibc

Linux

客户让访问外网,也不挂载本地系统盘,这需求估计也是遇到比较极端的了。没办法,抱怨归抱怨,事还是要干好。解决办法有两个:一是把系统packages文件夹下下来传到服务器,做本地yum源,这个看似最合理高效,可一看CentOSos6系统packages包含6000多个,大概4个多G。此时只能放弃,老老实实的一步一步用rpm安装,没有rpm包的就只能用编译安装。不管用rpm安装还是用编译安装都就将会面临着各种依赖缺失的问题。搞不懂为什么本来可以坐车的,缺偏偏要步行。因为汽车不安全吗?下面PHP程序员雷雪松详细的介绍一下rpm安装gcc和glib的步骤。

1
2
3
4
5
6
7
8
[root@localhost ~]# rpm -ivh ppl-0.10.2-11.el6.x86_64.rpm cloog-ppl-0.15.7-1.2.el6.x86_64.rpm mpfr-2.4.1-6.el6.x86_64.rpm cpp-4.4.7-18.el6.x86_64.rpm kernel-headers-2.6.32-696.el6.x86_64.rpm
[root@localhost ~]# rpm -q glibc #如有安装就不需要 没有就是用rpm命令安装
[root@localhost ~]# rpm -q glibc-common #如有安装就不需要 没有就是用rpm命令安装
[root@localhost ~]# rpm -ivh glibc-devel-2.12-1.209.el6
[root@localhost ~]# rpm -ivh libgomp-4.4.7-18.el6.x86_64.rpm
[root@localhost ~]# rpm -ivh gcc-4.4.7-18.el6.x86_64.rpm
[root@localhost ~]# rpm -ivh libstdc++-devel-4.4.7-18.el6.x86_64.rpm
[root@localhost ~]# rpm -ivh gcc-c++-4.4.7-18.el6.x86_64.rpm

注意:如果出现conflict版本冲突的问题,千万不要卸载重装。否则会出现系统崩溃的问题。正确的解决办法是查看已经安装的版本,使用现在的版本安装其他的rpm包。
问题最终还是圆满解决。事后大概总结以下四点:
1、不要太过乐观,有些事情的糟糕程度很可能会超过你的想象。
2、很多事很难,可没退路的时候就得破釜成舟。决心和魄力也是解决问题必不可少的。
3、不要思维定势,见招拆招,随机应变。武功的最高境界就是无招胜有招。大概就是一个道理吧。
4、面对困难,花时间研究。积累到一定的程度总会找到一丝转机。有些转机是在做的时候出现的,并不是干等就会有的。做总比等着什么都不干要强得多。

来源:CentOS6下RPM安装gcc和glibc

发表评论

电子邮件地址不会被公开。 必填项已用*标注