CentOS下yum安装新版PHP7

PHP

PHP7已经发布很多个版本了,性能更加好,运行也更稳定,并且很多框架也都支持PHP7。所以在目前项目开发中,PHP7是我们的首选版本。在CentOS系统下,我们比较快捷安装软件的命令就是yum。下面PHP程序员雷雪松就详细的介绍一下CentOS下如何使用yum安装新版PHP7。

1、首先要安装yum源

1
2
3
[root@centos ~]# rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
//安装webtatic-release之前需要先安装epel-release,否则会提示error: Failed dependencies:epel-release >= 7 is needed by webtatic-release-7-3.noarch
[root@VM_0_10_centos ~]# rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

2、使用yum安装php7和php7相关扩展

1
[root@centos ~]# yum install php70w-common php70w php70w-opcache php70w-gd php70w-mysqlnd php70w-mbstring php70w-devel

来源:CentOS下yum安装新版PHP7

7 评论 “CentOS下yum安装新版PHP7

    营销软件 评论:
    2018年3月4日 下午4:22

    新年虽已过,好运不打折!

    三五创业网 评论:
    2018年3月9日 下午2:43

    找了好久才找到这里,来了就不想走!

    付费阅读 评论:
    2018年3月10日 上午9:38

    非常不错。

    增大 评论:
    2018年3月25日 下午6:59

    受益匪浅,感触良多!

    百约不得姐 评论:
    2018年4月11日 下午6:34

    为啥我又来,因为这里百看不厌!

    跨境电商教程 评论:
    2018年4月23日 下午2:23

    新手学习了~~

    菜鸟博客 评论:
    2018年5月3日 下午5:47

    能用7.0不用7.1,我都被坑死了!

发表评论

电子邮件地址不会被公开。 必填项已用*标注